【1作目アップデート計画】#3 スクリプトを大幅に書き換え

スポンサーリンク

【1作目アップデート計画】記事一覧

 

【1作目アップデート計画】 前回の記事

 

スクリプトを見てみた

スクリプトを覗いてみたのですが、かなりヤバそう。

namespaceを分割してないとか、private変数にしていないとかは全然想定内でした。

 

しかし、想定外の汚いコードで驚きでした。

どう改善したかを書いていくとかなりの重労働になってしまうので、「どうやばかったか」だけ書いていきます。

 

変数名が全て大文字始まりのキャメルケース

public変数は大文字始まり、private変数は小文字始まりやアンダースコア始まりなどが一般的ですよね。

しかし、この頃はそんなことは全く知りませんでした。

 

こんな感じになってました。(やばい)

 

似たような曖昧なクラス名(ファイル名)

「SquareBehaviour.cs」と「OneSquareBehaviour.cs」があったりとか、中身が全く分からない状態。

 

この頃は「〜〜Behaviour」って付ければいいと思っていました。

 

判定が力技

マスが移動可能かを判定する処理がめっちゃ力技だった。

 

まだしっかり見てないから分からないけど、流石にもう少し綺麗に描けるはず・・・

 

何もしないスクリプト

削除しろ!

 

次の記事

コメント

タイトルとURLをコピーしました